Packages by fb <opensource+npm@fb.com> [SYNC profile]

Name IM Last modified Is admin Publish scopes
@fb Thu Apr 27 2017 22:28:12 GMT+0800 (China Standard Time) false

  • react-tools (latest: 0.13.3) A set of complementary tools to React, including the JSX transformer.
  • nuclide-diff-view (latest: 0.0.0) Provides Diff Viewer agnostic to the source control type of a project
  • xhpjs (latest: 1.0.0) Easily create JS controllers for XHP elements, and XHP wrappers for React elements
  • jstransform (latest: 11.0.3) A simple AST visitor-based JS transformer
  • esprima-fb (latest: 15001.1001.0-dev-harmony-fb) Facebook-specific fork of the esprima project
  • nuclide-panel (latest: 0.0.32) Provides support for new UI panels in Nuclide
  • nuclide-ui-pane (latest: 0.0.0) Provides support for custom panes in Nuclide
  • nuclide-package (latest: 0.0.0) Provides a base package class to avoid boilerplate in others
  • nuclide-remote-atom-base (latest: 0.0.0) Code that is common to nuclide-remote-atom-server and nuclide-remote-atom-client
  • css-layout (latest: 1.1.1) Reimplementation of CSS layout using pure JavaScript
  • nuclide-atom-helpers (latest: 0.0.35) Provides common helper functions for Nuclide packages in Atom
  • nuclide-atom-npm (latest: 0.0.35) Utility to load an Atom package that is packaged as a Node package
  • nuclide-inline-imports (latest: 0.0.35) Babel plugin that transforms ES6 import references into inline require calls
  • nuclide-jasmine (latest: 0.0.35) Atom-compatible Jasmine test runner that runs outside of Atom
  • nuclide-keystroke-label (latest: 0.0.35) Helpers for generating platform-specific, human-readabe keystroke labels. Ported from atom/underscore-plus.
  • nuclide-logging (latest: 0.0.35) Provides logging on both Nuclide client and Nuclide server
  • nuclide-remote-uri (latest: 0.0.35) RemoteUri - provides local and remote nuclide file path functions.
  • nuclide-task (latest: 0.0.35) Provides a utility to run babel code in a separate process
  • nuclide-ui-tabs (latest: 0.0.35) Provides a static tab-bar react component based on the native Atom tab styles
  • nuclide-analytics (latest: 0.0.35) Provides a standard API for packages to send analytics to arbitrary providers.
  • hyperclick-interfaces (latest: 0.0.35) Flow types for the hyperclick provider interface. This is a dev-only package. It does not contain executable code.
  • nuclide-clang (latest: 0.0.35) Provides support for the cxx family of languages via the clang compiler
  • nuclide-client (latest: 0.0.35) Provides abstractions for connecting to remote Nuclide servers
  • nuclide-hg-git-bridge (latest: 0.0.35) Helpers that account for the differences between Atom's GitRepository and Nuclide's HgRepositoryClient
  • nuclide-home-interfaces (latest: 0.0.35) This is a dev-only package containing Flow types for the home service interface.
  • nuclide-process-output (latest: 0.0.35) Provides a service for opening a new Atom pane with the output of a running process.
  • nuclide-quick-open-interfaces (latest: 0.0.35) Flow types for the public quick-open provider interface. This is a dev-only package. It does not contain executable code!
  • nuclide-server (latest: 0.0.35) Provides a collection of services that are run on the Nuclide server to support remote file editing
  • nuclide-service-parser (latest: 0.0.35) Provides support for developing services between Nuclide server and client
  • nuclide-ssh-dialog (latest: 0.0.35) Provides a dialog to allow Nuclide users to connect to remote servers
  • nuclide-text-event-dispatcher (latest: 0.0.35) Allows subscriptions to text editing events, at a higher level of abstraction than the included Atom events
  • nuclide-ui-dropdown (latest: 0.0.35) Provides a basic drop down menu for Nuclide user interfaces
  • nuclide-ui-panel (latest: 0.0.35) Provides support for new UI panels in Nuclide
  • nuclide-ui-tree (latest: 0.0.35) Provides abstract tree view functionality for Nuclide
  • nuclide-update-cursor (latest: 0.0.35) Utility to help update the position of the cursor when code changes
  • nuclide-gadgets-interfaces (latest: 0.0.0) Flow types for the public nuclide-gadgets service interface. This is a dev-only package. It does not contain executable code.
  • nuclide-textedit (latest: 0.0.0) Utilities and types for manipulating editor text
  • react-fetch (latest: 0.0.9) A component that fetches data from an api
  • node-haste (latest: 2.12.0) node-haste is a dependency management system for static resources for node.js. It provides the ability to statically resolve JavaScript module dependencies both for node module resolution and Facebook's haste module system.
  • react-for-atom (latest: 15.3.1-0) Require this to get a single instance of React in Atom. Addons are lazily loaded.
  • remodel-gen (latest: 1.1.0) Remodel generates Objective-C models that support coding, value comparison, and immutability.
  • simple-text-buffer (latest: 9.2.11) A version of Atom's text-buffer with marker layers and file support removed
  • ctags-prebuilt (latest: 0.2.3) A package for reading source code tag files prebuilt for Mac and Linux
  • fbjs-eslint-utils (latest: 1.0.0) Shared utilities for our eslint configuration packages.
  • babel-relay-plugin (latest: 0.11.0) Babel Relay Plugin for transpiling GraphQL queries for use with Relay.
  • react-native-template-master-detail (latest: 0.0.3) ![](https://github.com/hramos/react-native-template-master-detail/raw/master/.github/MasterScreen.ios.png?raw=true) ![](https://github.com/hramos/react-native-template-master-detail/raw/master/.github/MasterScreen.android.png?raw=true)
  • immutable-re (latest: 0.0.15) Persistent immutable collections for Reason
  • htmltojsx (latest: 0.3.0) Converts HTML to JSX for use with React
  • relay-devtools (latest: 1.4.0) Connect Relay DevTools to a Relay app.
  • react-addons-css-transition-group (latest: 15.6.2) The code in this package has moved. We recommend you to use `CSSTransitionGroup` from [`react-transition-group`](https://github.com/reactjs/react-transition-group) instead.
  • react-addons-linked-state-mixin (latest: 15.6.2) >**Note:** >This is a legacy React addon, and is no longer maintained. > >We don't encourage using it in new code, but it exists for backwards compatibility. >The recommended migration path is to explicitly set `value` and the `onChange` handler instead
  • react-addons-transition-group (latest: 15.6.2) The code in this package has moved. We recommend you to use `TransitionGroup` from [`react-transition-group`](https://github.com/reactjs/react-transition-group) instead.
  • react-static-container (latest: 1.0.2) Renders static content efficiently by allowing React to short-circuit the reconciliation process.
  • fixed-data-table (latest: 0.6.5) A React table component designed to allow presenting thousands of rows of data.
  • nuclide-format-js (latest: 0.0.42) A collection of codemods to help auto format javascript
  • yoga-layout (latest: 1.9.3) Yoga is a cross-platform layout engine enabling maximum collaboration within your team by implementing an API many designers are familiar with, and opening it up to developers across different platforms.
  • react-call-return (latest: 0.8.0) Experimental APIs for multi-pass rendering in React.
  • babel-plugin-idx (latest: 2.4.0) Babel plugin for transforming the idx utility function.
  • big-dig (latest: 0.7.2) Secure, re-connectable channel for bidirectional communication with a remote host.
  • atom-ide-ui (latest: 0.7.2) A suite of language service UIs for Atom.
  • schedule (latest: 0.5.0) Cooperative scheduler for the browser environment.
  • nuclide (latest: 0.366.0) A unified developer experience for web and mobile development, built as a suite of features on top of Atom to provide hackability and the support of an active community.
  • express-react-views (latest: 0.11.0) This is an Express view engine which renders React components on server. It renders static markup and *does not* support mounting those views on the client.
  • fbjs-css-vars (latest: 1.0.2) This package exports a few of the CSS variables that we use in Facebook projects. This is not the full list we have internally but focused on making available the minimum set needed by our open source projects.
  • graphql-relay (latest: 0.6.0) A library to help construct a graphql-js server supporting react-relay.
  • messenger-analytics (latest: 1.0.1) Facebook Analytics integration utility for Messenger bots
  • prop-types (latest: 15.7.2) Runtime type checking for React props and similar objects.
  • idx (latest: 2.5.6) Utility function for traversing properties on objects and arrays.
  • eslint-config-fbjs (latest: 3.1.1) For the most part, this configuration matches the ESLint configuration we have internally at Facebook.
  • eslint-config-fbjs-opensource (latest: 2.0.1) This configuration is a new ideal setup based on Facebook's internal configurations combined with the configurations that our open source projects are trending towards in a more modern code base. In particular, this is strongly based on Nuclide's ESLint r
  • hermesvm (latest: 0.1.1) A JavaScript engine optimized for running React Native on Android
  • dataloader (latest: 2.0.0) A data loading utility to reduce requests to a backend via batching and caching.
  • fbt-rn-android-native (latest: 0.0.2) Android native module to enable the usage of the FBT translation framework in React Native apps.
  • metro-visualizer (latest: 0.56.4) Suite of visual analysis tools for the metro bundler
  • jest-docblock (latest: 26.0.0) `jest-docblock` is a package that can extract and parse a specially-formatted comment called a "docblock" at the top of a file.
  • docusaurus (latest: 1.14.6) Easy to Maintain Open Source Documentation Websites
  • jest-get-type (latest: 26.3.0) A utility function to get the type of a value
  • eslint-config-fbcnms (latest: 0.2.1) This package provides Facebook NMS' eslint config as an extensible shared config. This is only used internally, use at your own risk
  • draft-js (latest: 0.11.7) A React framework for building text editors.
  • jscodeshift (latest: 0.11.0) A toolkit for JavaScript codemods
  • fbjs-scripts (latest: 3.0.0) A bundle of helpful scripts used in projects consuming fbjs.
  • fbjs (latest: 3.0.0) A collection of utility libraries used by other Facebook JS projects
  • create-subscription (latest: 17.0.0) utility for subscribing to external data sources inside React components
  • react-docgen (latest: 5.3.1) A CLI and toolkit to extract information from React components for documentation generation.
  • react (latest: 17.0.1) React is a JavaScript library for building user interfaces.
  • react-art (latest: 17.0.1) React ART is a JavaScript library for drawing vector graphics using React. It provides declarative and reactive bindings to the ART library. Using the same declarative API you can render the output to either Canvas, SVG or VML (IE8).
  • react-dom (latest: 17.0.1) React package for working with the DOM.
  • react-is (latest: 17.0.1) Brand checking of React Elements.
  • react-reconciler (latest: 0.26.1) React package for creating custom renderers.
  • scheduler (latest: 0.20.1) Cooperative scheduler for the browser environment.
  • react-app-polyfill (latest: 2.0.0) Polyfills for various browsers including commonly used language features
  • confusing-browser-globals (latest: 1.0.10) A list of browser globals that are often used by mistake instead of local variables
  • recoil (latest: 0.1.2) Recoil - A state management library for React
  • jest-serializer (latest: 26.6.2) Module for serializing and deserializing object into memory and disk. By default, the `v8` implementations are used, but if not present, it defaults to `JSON` implementation. Both serializers have the advantage of being able to serialize `Map`, `Set`, `un
  • jest-worker (latest: 26.6.2) Module for executing heavy tasks under forked processes in parallel, by providing a `Promise` based interface, minimum overhead, and bound workers.
  • diff-sequences (latest: 26.6.2) Compare items in two sequences to find a longest common subsequence
  • babel-preset-jest (latest: 26.6.2) > Babel preset for all Jest plugins. This preset is automatically included when using [babel-jest](https://github.com/facebook/jest/tree/master/packages/babel-jest).
  • babel-plugin-jest-hoist (latest: 26.6.2) Babel plugin to hoist `jest.disableAutomock`, `jest.enableAutomock`, `jest.unmock`, `jest.mock`, calls above `import` statements. This plugin is automatically included when using [babel-jest](https://github.com/facebook/jest/tree/master/packages/babel-jes
  • jest-changed-files (latest: 26.6.2) A module used internally by Jest to check which files have changed since you last committed in git or hg.
  • jest-diff (latest: 26.6.2) Display differences clearly so people can review changes confidently.
  • jest-matcher-utils (latest: 26.6.2) A set of utility functions for expect and related packages
  • jest-validate (latest: 26.6.2) Generic configuration validation tool that helps you with warnings, errors and deprecation messages as well as showing users examples of correct configuration.
  • jest-each (latest: 26.6.2) Parameterised tests for Jest
  • jest-leak-detector (latest: 26.6.2) Module for verifying whether an object has been garbage collected or not.
  • expect (latest: 26.6.2) This package exports the `expect` function used in [Jest](https://jestjs.io/). You can find its documentation [on Jest's website](https://jestjs.io/docs/en/expect.html).
  • jest-watcher (latest: 26.6.2) Delightful JavaScript Testing.
  • jest-phabricator (latest: 26.6.2) This Repo contains the testResultsProcessor needed to create the coverage map needed by Phabricator to show inline coverage at diff time.
  • babel-jest (latest: 26.6.3) Jest plugin to use babel for transformation.
  • @jest/core (latest: 26.6.3) Delightful JavaScript Testing.
  • jest-circus (latest: 26.6.3) <h1 align="center"> <img src="https://jestjs.io/img/jest.png" height="150" width="150"/> <img src="https://jestjs.io/img/circus.png" height="150" width="150"/> <p align="center">jest-circus</p> <p align="center">The next-gen test runner for Jest</
  • jest-cli (latest: 26.6.3) Delightful JavaScript Testing.
  • jest (latest: 26.6.3) Delightful JavaScript Testing.
  • buck-worker-tool (latest: 0.64.0) Implementation of the Buck worker protocol for Node.js.
  • ob1 (latest: 0.64.0) A small library for working with 0- and 1-based offsets in a type-checked way.
  • hermes-engine-darwin (latest: 0.5.3) A JavaScript engine optimized for running React Native on macOS
  • express-graphql (latest: 0.12.0) Production ready GraphQL HTTP middleware.
  • create-react-app (latest: 4.0.1) Create React apps with no build configuration.
  • react-dev-utils (latest: 11.0.1) webpack utilities used by Create React App
  • react-scripts (latest: 4.0.1) Configuration and scripts for Create React App.
  • react-native (latest: 0.63.4) A framework for building native apps using React
  • mephisto-task (latest: 1.0.13) This package provides two hooks to faciliate React-based front-end development for Mephisto tasks.
  • bootstrap-chat (latest: 1.0.7) A set of UI components based on [Bootstrap v3](https://react-bootstrap-v3.netlify.app/components/alerts/) for facilitating chat-based tasks for Mephisto.
  • internaldocs-fb-helpers (latest: 1.2.0) Helper library for including / excluding content from docusaurus websites
  • react-addons-pure-render-mixin (latest: 15.6.3) >**Note:** >This is a legacy React addon, and is no longer maintained. > >We don't encourage using it in new code, but it exists for backwards compatibility. >The recommended migration path is to use [`React.PureComponent`](https://facebook.github.io/re
  • react-addons-shallow-compare (latest: 15.6.3) >**Note:** >This is a legacy React addon, and is no longer maintained. > >We don't encourage using it in new code, but it exists for backwards compatibility. >The recommended migration path is to use [`React.PureComponent`](https://facebook.github.io/re
  • react-addons-update (latest: 15.6.3) >**Note:** >This is a legacy React addon, and is no longer maintained. > >We don't encourage using it in new code, but it exists for backwards compatibility. >The recommended migration path is to use [`immutability-helper`](https://github.com/kolodny/im
  • hermes-engine (latest: 0.7.2) A JavaScript engine optimized for running React Native on Android
  • react-relay (latest: 10.1.2) A framework for building GraphQL-driven React applications.
  • relay-compiler (latest: 10.1.2) A compiler tool for building GraphQL-driven applications.
  • relay-runtime (latest: 10.1.2) A core runtime for building GraphQL-driven applications.
  • @docusaurus/migrate (latest: 2.0.0-alpha.70) A cli tool to migrate between different version of Docusuarus
  • @docusaurus/types (latest: 2.0.0-alpha.70) Common used typings for Docusaurus packages
  • @docusaurus/utils (latest: 2.0.0-alpha.70) Node utility functions for Docusaurus packages
  • @docusaurus/core (latest: 2.0.0-alpha.70) Easy to Maintain Open Source Documentation Websites
  • @docusaurus/plugin-ideal-image (latest: 2.0.0-alpha.70) Docusaurus Plugin to generate an almost ideal image (responsive, lazy-loading, and low quality placeholder)
  • fbt (latest: 0.16.1) The fbt i18n framework JS runtime.
  • graphiql (latest: 1.3.2) An graphical interactive in-browser GraphQL IDE.
  • fbemitter (latest: 3.0.0) Facebook's EventEmitter is a simple emitter implementation that prioritizes speed and simplicity. It is conceptually similar to other emitters like Node's EventEmitter, but the precise APIs differ. More complex abstractions like the event systems used on
  • flux (latest: 4.0.1) An application architecture based on a unidirectional data flow
  • flipper (latest: 0.71.0) Mobile development tool
  • flipper-doctor (latest: 0.71.0) Utility for checking for issues with a flipper installation
  • flipper-pkg (latest: 0.71.0) Utility for building and publishing Flipper plugins
  • flipper-pkg-lib (latest: 0.71.0) Library for building and publishing Flipper plugins
  • flipper-plugin-lib (latest: 0.71.0) Library containing common Flipper plugin installation utilities

Copyright 2014 - 2016 © taobao.org |