vue-maker
Configuration and scripts for Create Vue App.
Last updated 5 months ago by king-ui .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install vue-maker 
SYNC missed versions from official npm registry.

Vue Maker

Version License

Create Vue apps with no build configuration.

vue vue-router vuex vuex-router-sync less postcss

Quick Start

npm i -g vue-maker
mkdir my-app
cd my-app
vue-maker init
vue-maker start

Build without sourcemap

vue-maker build

Build with sourcemap

vue-maker build --sourcemap

Directory structure

my-app
├── package.json
├── .gitignore
└── src
    ├── App.vue
    ├── index.html
    ├── index.js
    └── index.less

Configure homepage | buildPath | proxy | alias | externals | port | devtool | gzip | analysis | srchash

in package.json:
{
  "homepage": "./",
  "buildPath": "build",
  "proxy": {
    "['/api']": {
      "target": "http://localhost:3000",
      "secure": false,
      "changeOrigin": true
    }
  },
  "WEBPACK_CONFIG": {
    "srchash": false,
    "gzip": false,
    "analysis": false,
    "alias": {
      "@template": "./"
    },
    "devtool": "cheap-module-eval-source-map",
    "externals": {}
  },
  "DEV_SERVER_CONFIG": {
    "port": 3000
  }
}

Default internal config

{
  "WEBPACK_CONFIG": {
    "alias": {
      "@": "./src"
    }
  },
  "DEV_SERVER_CONFIG": {
    "port": 3000
  }
}

Included modules

vue
vuex
vue-router
vuex-router-sync

alloyfinger
fetch-jsonp

Included polyfills

Promise
fetch
Object.assign

Installed webpack loaders

babel-loader
vue-loader
vue-style-loader
style-loader
postcss-loader
css-loader
less-loader
file-loader
url-loader

Babel presets

const plugins = [
  require.resolve('babel-plugin-transform-vue-jsx'),
  require.resolve('babel-plugin-transform-es2015-destructuring'),
  require.resolve('babel-plugin-transform-class-properties'),
  require.resolve('babel-plugin-transform-decorators-legacy'),
  [
    require.resolve('babel-plugin-transform-object-rest-spread'),
    {
      useBuiltIns: true,
    },
  ],
  [
    require.resolve('babel-plugin-transform-runtime'),
    {
      helpers: false,
      polyfill: false,
      regenerator: true,
    },
  ],
];

module.exports = {
    presets: [
      [
        require.resolve('babel-preset-env'),
        {
          targets: {
            ie: 9,
            uglify: true,
          },
          useBuiltIns: false,
          modules: false,
        },
      ],
      require.resolve('babel-preset-stage-0'),
    ],
    plugins: plugins.concat([
      [
        require.resolve('babel-plugin-transform-regenerator'),
        {
          async: false,
        },
      ],
      require.resolve('babel-plugin-syntax-dynamic-import'),
    ]),
}

Postcss plugins

[
  require('postcss-flexbugs-fixes'),
  autoprefixer({
    browsers: [
    '>1%',
    'last 4 versions',
    'Firefox ESR',
    'not ie < 9',
    ],
  }),
]

Current Tags

  • 1.0.15                                ...           latest (5 months ago)

24 Versions

  • 1.0.15                                ...           5 months ago
  • 1.0.14                                ...           10 months ago
  • 1.0.13                                ...           10 months ago
  • 1.0.12 [deprecated]           ...           10 months ago
  • 1.0.11 [deprecated]           ...           10 months ago
  • 1.0.10 [deprecated]           ...           10 months ago
  • 1.0.9                                ...           10 months ago
  • 1.0.8                                ...           10 months ago
  • 1.0.7                                ...           a year ago
  • 1.0.6                                ...           a year ago
  • 1.0.5                                ...           a year ago
  • 1.0.4                                ...           a year ago
  • 1.0.3                                ...           a year ago
  • 1.0.2                                ...           a year ago
  • 1.0.1                                ...           a year ago
  • 0.0.9 [deprecated]           ...           a year ago
  • 0.0.8 [deprecated]           ...           a year ago
  • 0.0.7 [deprecated]           ...           a year ago
  • 0.0.6 [deprecated]           ...           a year ago
  • 0.0.5 [deprecated]           ...           a year ago
  • 0.0.4 [deprecated]           ...           a year ago
  • 0.0.3 [deprecated]           ...           a year ago
  • 0.0.2 [deprecated]           ...           a year ago
  • 1.0.0 [deprecated]           ...           a year ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 24
Last Day 0
Last Week 0
Last Month 2
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |