vue-doc-loader
Document loader for webpack
Last updated 2 years ago by dkypooh .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install vue-doc-loader 
SYNC missed versions from official npm registry.

Document loader for webpack

Installation

    npm install vue-doc-loader --save-dev

The vue-doc-loader requires vue-loader, vue-style-loader, 'css-loader'

Usage

    require("vue-doc-loader?doc=ysf-doc");

webpack config


    module.exports = {
      module: {
        loaders: [
            {
                test: /\.md$/,
                loader: require('vue-doc-loader'),
                query : "doc=ysf-doc"
            },
            {
                test: /\.vue$/,
                loader: 'vue'
            },
            {
                test: /\.js$/,
                exclude: /node_modules/,
                loader: 'babel'
            },
            {
                test: /\.css$/,
                loader: 'style!css'
            }
        ]
      },
        vue: {
            loaders: {
                scss: "vue-style-loader!css-loader!sass"
            }
        }
    };

License

MIT (http://www.opensource.org/licenses/mit-license.php)

Current Tags

  • 0.0.7                                ...           latest (2 years ago)

6 Versions

  • 0.0.7                                ...           2 years ago
  • 0.0.6                                ...           2 years ago
  • 0.0.5                                ...           2 years ago
  • 0.0.3                                ...           3 years ago
  • 0.0.2                                ...           3 years ago
  • 0.0.1                                ...           3 years ago
Maintainers (1)
Downloads
Today 0
This Week 6
This Month 12
Last Day 0
Last Week 0
Last Month 0
Dependencies (5)
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |