uptrend-scripts
CLI for common scripts for my projects
Last updated 9 months ago by orther .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install uptrend-scripts 
SYNC missed versions from official npm registry.

uptrend-scripts

CLI toolbox for common scripts for uptrend projects


Build Status Code Coverage version downloads MIT License

All Contributors PRs Welcome Code of Conduct

Watch on GitHub Star on GitHub Tweet

The problem

Creating new uptrend npm libraries requires a lot of boilerplate configuration, and is prone to errors. Configurations will often diverge or never be updated.

This solution

This is a CLI that abstracts away all configuration for my open source projects for linting, testing, building, and more.

Table of Contents

Installation

This module is distributed via npm which is bundled with node and should be installed as one of your project's devDependencies:

npm install --save-dev uptrend-scripts

Usage

This is a CLI and exposes a bin called uptrend-scripts.

This project actually dogfoods itself. If you look in the package.json, you'll find scripts with node src {scriptName}. This serves as an example of some of the things you can do with uptrend-scripts.

To use the after-success hooks and automatic semantic release, you need to set up your build env with GH_TOKEN and NPM_TOKEN.

If you want to automatically publish coverage reports to codecov, add a CODECOV_TOKEN.

<summary>Example `package.json`</summary>
{
  "name": "amazing-library",
  "version": "0.0.0-semantically-released",
  "main": "dist/index.js",
  "files": ["dist"],
  "scripts": {
    "test": "uptrend-scripts test",
    "test:update": "uptrend-scripts test --updateSnapshot",
    "build": "uptrend-scripts build",
    "lint": "uptrend-scripts lint",
    "format": "uptrend-scripts format",
    "validate": "uptrend-scripts validate",
    "precommit": "uptrend-scripts precommit",
    "after-success": "uptrend-scripts travis-after-success"
  },
  "devDependencies": {
    "uptrend-scripts": "1.0.0"
  }
}
<summary>Example `.travis.yml`</summary>
sudo: false
language: node_js
cache:
  directories:
    - node_modules
notifications:
  email: false
node_js:
  - '8'
script: npm run validate
after_success:
  - npm run after-success
branches:
  only:
    - master

Required Config

Prettier is run by eslint using eslint-plugin-prettier. Currently you MUST expose the prettier config from uptrend-scripts by creating .prettierrc.js in the root of your project with the following content:

const {prettier: prettierConfig} = require('uptrend-scripts/config')
module.exports = prettierConfig

Overriding Config

Unlike react-scripts, uptrend-scripts allows you to specify your own configuration for things and have that plug directly into the way things work with uptrend-scripts. There are various ways that it works, but basically if you want to have your own config for something, just add the configuration and uptrend-scripts will use that instead of it's own internal config. In addition, uptrend-scripts exposes its configuration so you can use it and override only the parts of the config you need to.

This can be a very helpful way to make editor integration work for tools like ESLint which require project-based ESLint configuration to be present to work.

So, if we were to do this for ESLint, you could create an .eslintrc with the contents of:

{"extends": "./node_modules/uptrend-scripts/eslint.js"}

Note: for now, you'll have to include an .eslintignore in your project until this eslint issue is resolved.

Or, for prettier, a .prettierrc.js with:

const {prettier: prettierConfig} = require('uptrend-scripts/config')
module.exports = Object.assign(prettierConfig, {
  // your overrides here
  printWidth: 100,
})

Or, for babel, a .babelrc with:

{"presets": ["uptrend-scripts/babel"]}

Or, for jest:

const {jest: jestConfig} = require('uptrend-scripts/config')
module.exports = Object.assign(jestConfig, {
  // your overrides here

  // for test written in Typescript, add:
  transform: {
    '\\.(ts|tsx)$': '<rootDir>/node_modules/ts-jest/preprocessor.js',
  },
})

Note: uptrend-scripts intentionally does not merge things for you when you start configuring things to make it less magical and more straightforward. Extending can take place on your terms. I think this is actually a great way to do this.

Inspiration

This is inspired by react-scripts.

Other Solutions

uptrend-scripts is a fork of kcd-scripts, adapted to Uptrend.

Contributors

Thanks goes to these people (emoji key):


Brandon Orther

???? ???? ????

Dony Sukardi

???? ????

Alexander Nanberg

????

Alex Liang

????

This project follows the all-contributors specification. Contributions of any kind welcome!

LICENSE

MIT

Current Tags

  • 0.43.0                                ...           latest (9 months ago)

5 Versions

  • 0.43.0                                ...           9 months ago
  • 0.42.0                                ...           9 months ago
  • 0.40.0                                ...           a year ago
  • 0.39.0                                ...           a year ago
  • 0.38.0                                ...           a year ago

Copyright 2014 - 2016 © taobao.org |