update-yeoman-generator
update-yeoman-generator - Update your Yeoman generator with style
Last updated 3 months ago by willmendesneto .
MIT · Original npm · Tarball · package.json
$ cnpm install update-yeoman-generator 
SYNC missed versions from official npm registry.

update-yeoman-generator

Greenkeeper badge

Update your Yeoman generator with style

MIT License PRs Welcome Watch on GitHub Star on GitHub Tweet

A script to help update repositories using Yeoman generators to the latest version.

Requirements

To use this package the generator should:

  • Creates a .yo-rc.json storing the version of your application. It should follow the Yeoman storage specs.
// .yo-rc.json
{
  "generator-poi": {
    "version": "1.0.0"
  }
}

Setup

Private repositories

If you are using this project for private repositories, you'll need to create a token with the notifications and repo permissions. After generate your token, pass the information token using the flag --github-token in your command.

update-yeoman-generator --generator <github-user>/<github-repository> --github-token <your-github-token>

Run update-yeoman-generator

Make sure you have npm@>=5.2.0:

npm install -g npm@latest

Parameters

  • -g, --generator [required] Name of the Github generator. It should be in format
    update-yeoman-generator --generator <github-user>/<github-repository>
  • --version [optional] Show package version number
  • --ejs-open [optional] [default: "<%"] .ejs File delimiter for open tag
  • --ejs-close [optional] [default: "%>"] .ejs File delimiter for close tag.
  • -t, --template [optional] [default: "app/templates"] String with a prefix for your templates folder based on the root folder of the generator repository.
  • --github-token [optional] Github Token required for private repositories
  • -h, --help [optional] Show help command

Inside the existing boilerplate generated repository run:

update-yeoman-generator

update-yeoman-generator will apply the changes from the latest version of boilerplate as a git style merge - so you'll still need to manually fix conflicts.

Usage

$ npm install -g update-yeoman-generator
$ cd <your-project-generated-using-yeoman-generator>
$ update-yeoman-generator --help
Options:
  --version        Show version number                                 [boolean]
  --github-token   Optional: Github Token required for private repositories.
  --ejs-open       Optional: '.ejs' File delimiter for open tag. Default:
                   "app/templates"
  --ejs-close      Optional: '.ejs' File delimiter for close tag. Default:
                   "app/templates"
  -h, --help       Show help                                           [boolean]
  -g, --generator  Name of the Github generator. It should be in format
                   `<github-user>/<github-repository>`                [required]
  -t, --template   Optional: String with a prefix for your templates folder
                   based on the root folder of the generator repository.
                   Default: "app/templates"

                   EX:

                   update-yeoman-generator --generator
                   willmendesneto/generate-poi --template-prefix
                   app/templates

                   update-yeoman-generator --generator
                   <github-user>/<github-repository> --github-token
                   <your-github-token> --template-prefix app/templates
                                                                        [string]



Copyright 2017

$ update-yeoman-generator --generator <github-user>/<github-repository>

Author

Wilson Mendes (willmendesneto)

Current Tags

  • 1.2.8                                ...           latest (3 months ago)

11 Versions

  • 1.2.8                                ...           3 months ago
  • 1.2.7                                ...           7 months ago
  • 1.2.6                                ...           10 months ago
  • 1.2.5                                ...           10 months ago
  • 1.2.4                                ...           a year ago
  • 1.2.3                                ...           a year ago
  • 1.2.2                                ...           a year ago
  • 1.2.1                                ...           2 years ago
  • 1.2.0                                ...           2 years ago
  • 1.1.0                                ...           2 years ago
  • 1.0.0                                ...           2 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 2
Last Day 0
Last Week 0
Last Month 12
Dependencies (10)
Dev Dependencies (5)

Copyright 2014 - 2016 © taobao.org |