spdx-correct
correct invalid SPDX expressions
Last updated a year ago by kemitchell .
Apache-2.0 · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install spdx-correct 
SYNC missed versions from official npm registry.
var correct = require('spdx-correct')
var assert = require('assert')

assert.equal(correct('mit'), 'MIT')

assert.equal(correct('Apache 2'), 'Apache-2.0')

assert(correct('No idea what license') === null)

// disable upgrade option
assert(correct('GPL-3.0'), 'GPL-3.0-or-later')
assert(correct('GPL-3.0', { upgrade: false }), 'GPL-3.0')

Current Tags

  • 3.1.0                                ...           latest (a year ago)

16 Versions

  • 3.1.0                                ...           a year ago
  • 3.0.2                                ...           a year ago
  • 3.0.1                                ...           a year ago
  • 3.0.0                                ...           2 years ago
  • 2.0.4                                ...           2 years ago
  • 2.0.3                                ...           2 years ago
  • 2.0.2                                ...           2 years ago
  • 2.0.1                                ...           2 years ago
  • 2.0.0                                ...           3 years ago
  • 1.0.2                                ...           4 years ago
  • 1.0.1                                ...           4 years ago
  • 1.0.0                                ...           4 years ago
  • 1.0.0-prerelease-4                                ...           4 years ago
  • 1.0.0-prerelease-3                                ...           4 years ago
  • 1.0.0-prerelease-2                                ...           4 years ago
  • 1.0.0-prerelease-1                                ...           4 years ago

Copyright 2014 - 2017 © taobao.org |