react-app-polyfill
Polyfills for various browsers including commonly used language features
Last updated 2 days ago by iansu .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install react-app-polyfill 
SYNC missed versions from official npm registry.

react-app-polyfill

This package includes polyfills for various browsers. It includes minimum requirements and commonly used language features used by Create React App projects.

Usage

First, install the package using Yarn or npm:

npm install react-app-polyfill

or

yarn add react-app-polyfill

Supporting Internet Explorer

You can import the entry point for the minimal version you intend to support to ensure that the minimum langauge features are present that are required to use Create React App. For example, if you import the IE9 entry point, this will include IE10 and IE11 support.

These modules ensure the following language features are present:

  1. Promise (for async / await support)
  2. window.fetch (a Promise-based way to make web requests in the browser)
  3. Object.assign (a helper required for Object Spread, i.e. { ...a, ...b })
  4. Symbol (a built-in object used by for...of syntax and friends)
  5. Array.from (a built-in static method used by array spread, i.e. [...arr])

If you need more features, see the Polyfilling other language features section below.

Internet Explorer 9

// This must be the first line in src/index.js
import 'react-app-polyfill/ie9';

// ...

Internet Explorer 11

// This must be the first line in src/index.js
import 'react-app-polyfill/ie11';

// ...

Polyfilling other language features

You can also polyfill stable language features not available in your target browsers. If you're using this in Create React App, it will automatically use the browserslist you've defined to only include polyfills needed by your target browsers when importing the stable polyfill. Make sure to follow the Internet Explorer steps above if you need to support Internet Explorer in your application.

// This must be the first line in src/index.js
import 'react-app-polyfill/stable';

// ...

If you are supporting Internet Explorer 9 or Internet Explorer 11 you should include both the ie9 or ie11 and stable modules:

For IE9:

// These must be the first lines in src/index.js
import 'react-app-polyfill/ie9';
import 'react-app-polyfill/stable';

// ...

For IE11:

// These must be the first lines in src/index.js
import 'react-app-polyfill/ie11';
import 'react-app-polyfill/stable';

// ...

Current Tags

  • 1.0.0                                ...           latest (2 days ago)
  • 1.0.0-next.74                                ...           next (7 days ago)

14 Versions

  • 1.0.0                                ...           2 days ago
  • 1.0.0-next.74                                ...           7 days ago
  • 1.0.0-next.b0cbf2ca                                ...           a month ago
  • 0.2.2                                ...           2 months ago
  • 0.2.1                                ...           2 months ago
  • 0.2.1-next.6a95aae9                                ...           4 months ago
  • 0.2.0                                ...           4 months ago
  • 0.1.4-next.c662dfb0                                ...           6 months ago
  • 0.1.4-next.9b4009d7                                ...           6 months ago
  • 0.1.3                                ...           7 months ago
  • 0.1.2                                ...           7 months ago
  • 0.1.1                                ...           7 months ago
  • 0.1.0                                ...           7 months ago
  • 0.0.0                                ...           7 months ago
Downloads
Today 47
This Week 4,529
This Month 24,869
Last Day 1,546
Last Week 7,123
Last Month 32,410
Dependencies (6)
Dev Dependencies (0)
None
Dependents (898)

Copyright 2014 - 2016 © taobao.org |