postcss-safe-parser
Fault-tolerant CSS parser for PostCSS
Last updated a year ago by ai .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install postcss-safe-parser 
SYNC missed versions from official npm registry.

PostCSS Safe Parser Build Status

A fault-tolerant CSS parser for PostCSS, which will find & fix syntax errors, capable of parsing any input. It is useful for:

  • Parse legacy code with many hacks. For example, it can parse all examples from Browserhacks.
  • Works with demo tools with live input like Autoprefixer demo.
Sponsored by Evil Martians

Usage

var safe   = require('postcss-safe-parser');
var badCss = 'a {';

postcss(plugins).process(badCss, { parser: safe }).then(function (result) {
    result.css //= 'a {}'
});

Current Tags

  • 4.0.1                                ...           latest (a year ago)

14 Versions

  • 4.0.1                                ...           a year ago
  • 4.0.0                                ...           a year ago
  • 3.0.1                                ...           2 years ago
  • 3.0.0                                ...           2 years ago
  • 2.0.1                                ...           2 years ago
  • 2.0.0                                ...           3 years ago
  • 1.0.7                                ...           3 years ago
  • 1.0.6                                ...           3 years ago
  • 1.0.5                                ...           3 years ago
  • 1.0.4                                ...           3 years ago
  • 1.0.3                                ...           3 years ago
  • 1.0.2                                ...           4 years ago
  • 1.0.1                                ...           4 years ago
  • 1.0.0                                ...           4 years ago
Maintainers (1)
Downloads
Today 39
This Week 7,445
This Month 44,660
Last Day 3,726
Last Week 19,603
Last Month 79,308
Dependencies (1)
Dependents (1226)

Copyright 2014 - 2016 © taobao.org |