noodle-cli
> 希望傻瓜都能用node写代码
Last updated a year ago by luhuijian .
ISC · Original npm · Tarball
$ cnpm install noodle-cli 
SYNC missed versions from official npm registry.

Noodle

希望傻瓜都能用node写代码

快速上手

noodle-cli

  • 首先确保是在 NPM 3+, Node 4+, Python 2.7+ 环境下运行 *

第一步: 安装 noodle 命令行工具

npm i noodle-cli -g

第二步: 创建项目

noodle create api-project koa

第三步:启动应用

noodle dev

CLI

初始化

create <project-name> [framework-name]

创建项目目录生成基于框架的项目架子

# 创建 my-project 目录并初始化基于 koa 框架的脚手架
noodle create my-project koa

create [framework-name]

初始化基于框架的项目架子

# 初始化基于 koa 框架的脚手架
noodle init koa

开发

dev

启动项目

doc

生成API文档

api-doc

test

启动项目测试

api-test

模板

upgrade

升级模板架子

# 升级基于 koa 框架的脚手架
noodle upgrade koa

remove

删除模板架子

# 删除基于 koa 框架的脚手架
noodle remove koa
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 6
Dependencies (11)
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |