install-me-maybe
Installs your NPM modules only if they are out of date, designed for CI / CD systems
Last updated 7 months ago by rlancer .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install install-me-maybe 
SYNC missed versions from official npm registry.

Idempotent NPM Installs

oclif Version Downloads/week License

Works with Yarn or NPM!

Designed for CI / CD systems. Run install-me-maybe as many times as you'd like, it will only run npm install or yarn when the lock file changed.

How it works

Creates a hash of your package-lock.json or yarn.lock and writes that hash to a file called .installmemaybe

On the next call to install-me-maybe the contents of the hash file are compared with the new hash, only then will an install be triggered.

Installs your NPM modules only if they are out of date, designed for CI / CD systems

Current Tags

  • 0.0.6                                ...           latest (7 months ago)

7 Versions

  • 0.0.6                                ...           7 months ago
  • 0.0.5                                ...           7 months ago
  • 0.0.4                                ...           7 months ago
  • 0.0.3                                ...           10 months ago
  • 0.0.2                                ...           10 months ago
  • 0.0.1                                ...           10 months ago
  • 0.0.0                                ...           10 months ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 0
Dependencies (4)
Dev Dependencies (5)
Dependents (0)
None

Copyright 2014 - 2017 © taobao.org |