gulp-es-check
Gulp plugin for check ecma version
Last updated 4 months ago by jitui .
ISC · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install gulp-es-check 
SYNC missed versions from official npm registry.

gulp-es-check

gulp插件,用于检查javascript语法是否符合规范

使用方式

const esCheck = require("./util/gulp-es-check");

gulp.task('task-esCheck', () => {
  return gulp.src('./**/*.html')
    .pipe(esCheck({
      ecmaVersion: 'es5'
    }))
});

参数列表

参数名称 类型 说明
ecmaVersion string ECMAScript

ECMAScript版本对照

ecmaVersion
es3
es4
es5
es6
es7
es8
es9
es10
es2015
es2016
es2017
es2018
es2019

具体可以参考acorn模块包,也可以看下源码,很简单的。

Current Tags

  • 1.0.0                                ...           latest (4 months ago)

1 Versions

  • 1.0.0                                ...           4 months ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 1
Dependencies (3)
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |