felt-rollup
Rollup plugin for Felt
Last updated 3 years ago by cognitom .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install felt-rollup 
SYNC missed versions from official npm registry.

felt-rollup

Build Status

Rollup plugin for Felt.

Installation

$ npm install felt-postcss

Usage

const
  express = require('express'),
  felt = require('felt'),
  rollup = require('felt-rollup'),
  buble = require('rollup-plugin-buble'),
  resolve = require('rollup-plugin-node-resolve'),
  commonjs = require('rollup-plugin-commonjs')

const app = express()

app.use(felt({
  src: 'public'
  handlers: {
    '.js': rollup({
      plugins: [
        resolve({ jsnext: true,  main: true, browser: true }),
        commonjs(),
        buble()
      ],
      sourceMap: true
    })
  }
}))
app.use(express.static('public'))
app.listen(3000)

Current Tags

  • 0.1.2                                ...           latest (3 years ago)

4 Versions

  • 0.1.2                                ...           3 years ago
  • 0.1.1                                ...           3 years ago
  • 0.1.0                                ...           3 years ago
  • 0.0.1                                ...           3 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 0
Last Day 0
Last Week 0
Last Month 2
Dependencies (2)
Dev Dependencies (6)

Copyright 2014 - 2017 © taobao.org |