eslint-plugin-mocha
Eslint rules for mocha.
Last updated 10 days ago by lo1tuma .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install eslint-plugin-mocha 
SYNC missed versions from official npm registry.

NPM Version GitHub Actions status Coverage Status Peer Dependencies NPM Downloads

eslint-plugin-mocha

ESLint rules for mocha.

Install and configure

This plugin requires ESLint 4.0.0 or later.

npm install --save-dev eslint-plugin-mocha

Then add a reference to this plugin and selected rules in your eslint config:

{
  "plugins": [
    "mocha"
  ],
}

Recommended config

This plugin exports a recommended config that enforces good practices.

Enable it with the extends option:

{
  "extends": [
    "plugin:mocha/recommended"
  ],
}

See Configuring Eslint on eslint.org for more info.

Rules documentation

The documentation of the rules can be found here.

Current Tags

  • 6.3.0                                ...           latest (10 days ago)

43 Versions

  • 6.3.0                                ...           10 days ago
  • 6.2.2                                ...           3 months ago
  • 6.2.1                                ...           4 months ago
  • 6.2.0                                ...           4 months ago
  • 6.1.1                                ...           6 months ago
  • 6.1.0                                ...           6 months ago
  • 6.0.0                                ...           7 months ago
  • 5.3.0                                ...           a year ago
  • 5.2.1                                ...           a year ago
  • 5.2.0                                ...           2 years ago
  • 5.1.0                                ...           2 years ago
  • 5.0.0                                ...           2 years ago
  • 4.12.1                                ...           2 years ago
  • 4.12.0                                ...           2 years ago
  • 4.11.0                                ...           3 years ago
  • 4.10.1                                ...           3 years ago
  • 4.10.0                                ...           3 years ago
  • 4.9.0                                ...           3 years ago
  • 4.8.0                                ...           3 years ago
  • 4.7.0                                ...           3 years ago
  • 4.6.0                                ...           3 years ago
  • 4.5.1                                ...           3 years ago
  • 4.5.0                                ...           4 years ago
  • 4.4.0                                ...           4 years ago
  • 4.3.0                                ...           4 years ago
  • 4.2.0                                ...           4 years ago
  • 4.1.0                                ...           4 years ago
  • 4.0.0                                ...           4 years ago
  • 3.0.0                                ...           4 years ago
  • 2.2.0                                ...           4 years ago
  • 2.1.0                                ...           4 years ago
  • 2.0.0                                ...           4 years ago
  • 1.1.0                                ...           4 years ago
  • 1.0.0                                ...           4 years ago
  • 0.5.1                                ...           5 years ago
  • 0.5.0                                ...           5 years ago
  • 0.4.0                                ...           5 years ago
  • 0.3.0                                ...           5 years ago
  • 0.2.2                                ...           5 years ago
  • 0.2.1                                ...           5 years ago
  • 0.2.0                                ...           5 years ago
  • 0.1.1                                ...           5 years ago
  • 0.1.0                                ...           5 years ago
Downloads
Today 61
This Week 647
This Month 2,203
Last Day 123
Last Week 644
Last Month 1,799
Dependencies (2)
Dev Dependencies (8)
Dependents (329)

Copyright 2014 - 2016 © taobao.org |