eslint-plugin-compat
Lint browser compatibility of API used
Last updated 4 days ago by amilajack .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install eslint-plugin-compat 
SYNC missed versions from official npm registry.

eslint-plugin-compat

Build Status NPM version Dependency Status npm Backers on Open Collective Sponsors on Open Collective

Lint the browser compatibility of your code

demo of plugin usage

Setup

1. Install

npm install --save-dev eslint-plugin-compat

2. Update ESLint Config

// .eslintrc.json
{
  "extends": ["plugin:compat/recommended"],
  "env": {
    "browser": true
  },
  // ...
}

3. Configure Target Browsers

Browser targets are configured using browserslist. You can configure browser targets in your package.json:

package.json

{
  // ...
  "browserslist": ["chrome 70", "last 1 versions", "not ie <= 8"]
}

If no configuration is found, browserslist defaults to "> 0.5%, last 2 versions, Firefox ESR, not dead".

See browserslist/browserslist for more details.

Adding Polyfills

v3

Add polyfills to the settings section of your eslint config. Append the name of the object and the property if one exists. Here are some examples:

{
  // ...
  "settings": {
    "polyfills": [
      // Example of marking entire API and all methods and properties as polyfilled
      "Promise",
      // Example of marking specific method of an API as polyfilled
      "WebAssembly.compile",
      // Example of API with no property (i.e. a function)
      "fetch",
      // Example of instance method, must add `.prototype.`
      "Array.prototype.push"
    ]
  }
}

v2

See wiki polyfills section

Demo

For a minimal demo, see amilajack/eslint-plugin-compat-demo

Advanced

Support

If this project is saving you (or your team) time, please consider supporting it on Patreon ???? thank you!

Road Map

See the Road Map for the details.

Inspiration

Toolchains for native platforms, like iOS and Android, have had API linting from the start. It's about time that the web had similar tooling.

This project was inspired by a two hour conversation I had with someone on the experience of web development and if it is terrible or not. The premise they argued was that x browser doesn't support y feature while z browser does. Eventually, I agreed with him on this and checked made this plugin to save web developers from having to memorize browser compatibility of specs.

Related

Current Tags

  • 3.3.0                                ...           latest (4 days ago)
  • 3.3.0-1                                ...           next (17 days ago)

55 Versions

  • 3.3.0                                ...           4 days ago
  • 3.3.0-1                                ...           17 days ago
  • 3.3.0-0                                ...           19 days ago
  • 3.2.0                                ...           23 days ago
  • 3.1.2                                ...           a month ago
  • 3.1.1                                ...           3 months ago
  • 3.1.0                                ...           4 months ago
  • 3.1.0-0                                ...           4 months ago
  • 3.0.2-0                                ...           4 months ago
  • 3.0.1                                ...           4 months ago
  • 3.0.1-1                                ...           4 months ago
  • 3.0.1-0                                ...           4 months ago
  • 3.0.0                                ...           4 months ago
  • 3.0.0-1                                ...           5 months ago
  • 3.0.0-0                                ...           5 months ago
  • 2.7.0                                ...           5 months ago
  • 2.6.3                                ...           9 months ago
  • 2.6.2                                ...           9 months ago
  • 2.6.1                                ...           10 months ago
  • 2.6.0                                ...           10 months ago
  • 2.6.0-1                                ...           10 months ago
  • 2.6.0-0                                ...           10 months ago
  • 2.5.1 [deprecated]           ...           a year ago
  • 2.5.0                                ...           a year ago
  • 2.4.0                                ...           a year ago
  • 2.3.0                                ...           a year ago
  • 2.3.0-0                                ...           a year ago
  • 2.2.1-0                                ...           a year ago
  • 2.2.0                                ...           a year ago
  • 2.1.0                                ...           2 years ago
  • 2.0.1                                ...           2 years ago
  • 2.0.0                                ...           2 years ago
  • 1.0.4                                ...           2 years ago
  • 1.0.3                                ...           2 years ago
  • 1.0.2                                ...           2 years ago
  • 1.0.2-1                                ...           2 years ago
  • 1.0.2-0                                ...           2 years ago
  • 1.0.1                                ...           2 years ago
  • 1.0.0                                ...           3 years ago
  • 1.0.0-2                                ...           3 years ago
  • 1.0.0-1                                ...           3 years ago
  • 1.0.0-0                                ...           3 years ago
  • 0.1.3                                ...           3 years ago
  • 0.1.2                                ...           3 years ago
  • 0.1.1                                ...           3 years ago
  • 0.1.0                                ...           3 years ago
  • 0.0.8-0                                ...           3 years ago
  • 0.0.7                                ...           3 years ago
  • 0.0.6                                ...           3 years ago
  • 0.0.5                                ...           3 years ago
  • 0.0.4                                ...           3 years ago
  • 0.0.4-0                                ...           3 years ago
  • 0.0.3-0                                ...           3 years ago
  • 0.0.2-0                                ...           3 years ago
  • 0.0.1                                ...           3 years ago
Maintainers (1)
Downloads
Today 61
This Week 10,458
This Month 30,372
Last Day 1,936
Last Week 9,393
Last Month 32,904
Dependencies (7)
Dev Dependencies (16)
Dependents (184)

Copyright 2014 - 2016 © taobao.org |