eslint-config-blackdice
> We are using tabs, you can go away now ;)
Last updated 3 years ago by fredyc .
MIT · Original npm · Tarball · package.json
$ cnpm install eslint-config-blackdice 
SYNC missed versions from official npm registry.

ESLint BlackDice config

We are using tabs, you can go away now ;)

Configuration used in our projects based on great Airbnb with couple tweaks we like better.

NPM

eslintrc.yml

extends: blackdice

In this case it's also necessary to install peer dependency of eslint package itself.

Next gen

Alternatively if some of EcmaScript proposal features are used, following will use Babel parser instead of ESlint default one to support those.

eslintrc.yml

extends: blackdice/next

In this two other packages needs to be installed: babel-eslint & eslint-plugin-babel. Along those you will obviously need other Babel related packages like some presets and plugins that do actual parsing. Most likely one of stage plugins is a good idea, otherwise you don't to use this extended config at all.

Current Tags

  • 0.2.0                                ...           latest (3 years ago)

3 Versions

  • 0.2.0                                ...           3 years ago
  • 0.1.1                                ...           3 years ago
  • 0.1.0                                ...           3 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 1
Last Day 0
Last Week 0
Last Month 5
Dev Dependencies (1)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |