blamo
Bukwild's Nuxt starter template and bootstrapping module
Last updated 10 months ago by weotch .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install blamo 
SYNC missed versions from official npm registry.

Blamo

This forks the official Nuxt starter template and adds elements of Bukwild's default stack including:

As much as possible is moved to a Nuxt module (at module/index.js) so that configuration isn't hard coded into your app and can receive npm updates.

Prerequisites

Make sure to have node 8.0+ and npm 5.0+ installed

Installation

This is a project template for vue-cli.

$ vue init BKWLD/blamo my-project  # or vue init BKWLD/blamo .
$ cd my-project                     
# install dependencies
$ yarn

Make sure to use a version of vue-cli >= 2.1 (vue -V).

Usage

See the template's README

Config

Many defaults can be disabled with the following options:

module.exports =
	modules: ['blamo', 
		noCjsVue: false
		noSentry: false
		noMaxChunkSize: false
		noRobots: false
		noBalanceText: false
		noUnorphan: false
		noFailCodeOnGenerateError: false
	]

Current Tags

  • 1.4.0                                ...           latest (10 months ago)

8 Versions

  • 1.4.0                                ...           10 months ago
  • 1.3.0                                ...           a year ago
  • 1.2.0                                ...           a year ago
  • 1.1.1                                ...           a year ago
  • 1.1.0                                ...           a year ago
  • 1.0.2                                ...           a year ago
  • 1.0.1                                ...           a year ago
  • 1.0.0                                ...           a year ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 8
Last Day 0
Last Week 0
Last Month 9
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2017 © taobao.org |