babel-preset-shopify
Shopify's org-wide Babel preset
Last updated 22 days ago by shopify-dep .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install babel-preset-shopify 
SYNC missed versions from official npm registry.

babel-preset-shopify

NPM version

Shopify’s org-wide set of Babel transforms.

Usage

Install this package, as well as the parts of Babel you wish to use:

With Yarn

yarn add --dev --exact babel-core babel-preset-shopify

With npm

npm install babel-core babel-preset-shopify --save-dev --save-exact

Then, in your Babel configuration (which should be under the babel key of your package.json), set this package as the babel preset you’d like to use:

{
  "babel": {
    "presets": ["babel-preset-shopify/web"]
  }
}

Presets

This packages comes with several different presets for you to use, depending on your project:

  • babel-preset-shopify: The same as babel-preset-shopify/web.

  • babel-preset-shopify/web: A preset to use for JavaScript that is meant to run in browsers. It compiles down features to only those supported by browsers that you have specified in your browserslist config. Note that many modern JavaScript features, like Maps, Sets, for of loops, and more, require runtime polyfills (we recommend @shopify/polyfills, as our web and node configs will reduce these imports to the set of features needed to polyfill your target environment).

    This preset accepts an options object. The following options are allowed:

    • modules, a boolean indicating whether native ES2015 modules should be transpiled to CommonJS equivalents. Set this option to false when you are using a bundler like Rollup or Webpack 2:

      {
        "babel": {
          "presets": [
            ["babel-preset-shopify/web", {"modules": false}]
          ]
        }
      }
      
    • browsers, a browserslist string or array, which specifies which browsers to transpile for. We recommend setting your target browsers using a browserslist key in package.json, as that method will automatically be used by all browserslist-compatible tools.

      {
        "babel": {
          "presets": [
            ["babel-preset-shopify/web", {
              "browsers": ["last 3 versions"]
            }]
          ]
        }
      }
      
    • typescript, a boolean (defaults to false) to turn on @babel/preset-typescript and other plugins that allow babel to read typescript files directly.

    • inlineEnv, a boolean (defaults to false) to automatically replace process.env.<VAR> statements with the corresponding environment variable.

    • debug, a boolean (defaults to false) to turn on @babel/preset-env debugging.

    • corejs, a number of string that will be used to set the corejs version to use

    • useBuiltIns, a string that is passed to the useBuiltIns option of @babel/preset-env

  • babel-preset-shopify/node: This preset transpiles features to a specified version of Node, defaulting to the currently active version. It accepts an options object. The modules, typescript, inlineEnv,debug, corejs and useBuiltIns options do the same thing they do in babel-preset-shopify/web, detailed above. You can also pass a version of Node to target during transpilation using the version option:

    {
      "babel": {
        "presets": [
          ["babel-preset-shopify/node", {
            "modules": false,
            "version": 4
          }]
        ]
      }
    }
    
  • babel-preset-shopify/react: Adds plugins that transform React (including JSX). You can use this preset with the babel-preset-shopify/web or babel-preset-shopify/node configuration.

    This preset accepts an options object.

    • hot : Will automatically add plugins to enable hot reloading of React components. Note that this requires you to have a recent version of react-hot-loader installed as a dependency in your project.
    • pragma : Replace the function used when compiling JSX expressions. Defaults to React.createElement.
    • pragmaFrag: Replace the function used when compiling JSX fragment expressions. Defaults to React.Fragment.
    {
      "babel": {
        "presets": [
          ["babel-preset-shopify/react", {"hot": true}]
        ]
      }
    }
    

As noted above, you can include multiple of these presets together. Some common recipes are shown below:

// A React project without any server component, using sprockets-commoner for bundling
{
  "babel": {
    "presets": [
      "babel-preset-shopify/web",
      "babel-preset-shopify/react"
    ]
  }
}

// A Node project using Rollup to create a single bundle
{
  "babel": {
    "presets": [
      ["babel-preset-shopify/node", {"modules": false}]
    ]
  }
}

Current Tags

  • 20.1.0                                ...           latest (22 days ago)
  • 17.0.0-beta.9                                ...           next (a year ago)

38 Versions

  • 20.1.0                                ...           22 days ago
  • 20.0.0                                ...           4 months ago
  • 19.1.1                                ...           4 months ago
  • 19.1.0                                ...           5 months ago
  • 19.0.1                                ...           5 months ago
  • 19.0.0                                ...           5 months ago
  • 18.1.1                                ...           5 months ago
  • 18.1.0                                ...           6 months ago
  • 18.0.0                                ...           7 months ago
  • 17.0.1                                ...           9 months ago
  • 17.0.0                                ...           9 months ago
  • 16.7.0                                ...           10 months ago
  • 17.0.0-beta.9                                ...           a year ago
  • 17.0.0-beta.8                                ...           a year ago
  • 17.0.0-beta.7                                ...           a year ago
  • 16.6.0                                ...           a year ago
  • 16.5.0                                ...           a year ago
  • 16.3.0                                ...           2 years ago
  • 17.0.0-beta.6                                ...           2 years ago
  • 17.0.0-beta.5                                ...           2 years ago
  • 17.0.0-beta.4                                ...           2 years ago
  • 17.0.0-beta.3                                ...           2 years ago
  • 17.0.0-beta.2                                ...           2 years ago
  • 17.0.0-beta.1                                ...           2 years ago
  • 16.2.0                                ...           2 years ago
  • 16.1.0                                ...           2 years ago
  • 16.0.2                                ...           3 years ago
  • 16.0.1                                ...           3 years ago
  • 16.0.0                                ...           3 years ago
  • 15.0.1                                ...           3 years ago
  • 15.0.0                                ...           3 years ago
  • 13.0.0                                ...           3 years ago
  • 12.3.4                                ...           3 years ago
  • 12.3.3                                ...           3 years ago
  • 11.3.1-0                                ...           3 years ago
  • 11.3.0                                ...           3 years ago
  • 10.1.0                                ...           4 years ago
  • 10.0.0                                ...           4 years ago

Copyright 2014 - 2017 © taobao.org |