babel-preset-es2015-ng-compat
Babel preset for all es2015 plugins. Removed problematic problems with angular dep injection.
Last updated 3 years ago by gigigo .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install babel-preset-es2015-ng-compat 
SYNC missed versions from official npm registry.

babel-preset-es2015-ng-compat

Babel preset for all es2015 plugins. Removed some problematic plugins.

Install

npm install --save-dev babel-preset-es2015-ng-compat

Usage

Via .babelrc (Recommended)

.babelrc

{
  "presets": ["es2015-ng-compat"]
}

Via CLI

babel script.js --presets es2015-ng-compat

Via Node API

require("babel-core").transform("code", {
  presets: ["es2015-ng-compat"]
});

Options

loose

boolean, defaults to false.

Enable "loose" transformations for any plugins in this preset that allow them.

modules

"amd" | "umd" | "systemjs" | "commonjs" | false, defaults to "commonjs".

Enable transformation of ES6 module syntax to another module type.

Setting this to false will not transform modules.

spec

boolean, defaults to false.

Enable "spec" transformations for any plugins in this preset that allow them.

Current Tags

  • 6.22.0                                ...           latest (3 years ago)

1 Versions

  • 6.22.0                                ...           3 years ago

Copyright 2014 - 2016 © taobao.org |