babel-plugin-dynamic-import-system-import
Babel plugin to transpile import() to System.import()
Last updated 3 years ago by chicoxyzzy .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install babel-plugin-dynamic-import-system-import 
SYNC missed versions from official npm registry.

babel-plugin-dynamic-import-system-import

Babel plugin to transpile import() to System.import().

NOTE: Babylon >= v6.12.0 is required to correct parse dynamic imports.

Installation

$ npm install babel-plugin-dynamic-import-system-import --save-dev

Usage

Via .babelrc (Recommended)

.babelrc

{
  "plugins": ["dynamic-import-system-import"]
}

Via CLI

$ babel --plugins dynamic-import-system-import script.js

Via Node API

require('babel-core').transform('code', {
  plugins: ['dynamic-import-system-import']
});

Current Tags

  • 1.0.0                                ...           latest (3 years ago)

1 Versions

  • 1.0.0                                ...           3 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 1
Last Day 0
Last Week 1
Last Month 4
Dependencies (2)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |