@workast/eslint-config-node
Eslint configs for NodeJS projects
Last updated a year ago by orlandovallejos .
Apache-2.0 · Repository · Original npm · Tarball · package.json
$ cnpm install @workast/eslint-config-node 
SYNC missed versions from official npm registry.

Workast Eslint Config for NodeJs

Requirements

  • Node >= 8.0.0
  • Eslint >= 4.9.0

Installation

Install the package as a dev dependency along with its peer dependencies

$ npm install eslint eslint-plugin-import @workast/eslint-config-node --save-dev

Extend it in your .eslintrc.json config file

{
  "extends": "@workast/eslint-config-node"
}

If your project is based on react, then use it like this:

Extend it in your .eslintrc.json config file

{
  "extends": "@workast/eslint-config-node/react"
}

Current Tags

  • 1.1.0                                ...           latest (a year ago)

3 Versions

  • 1.1.0                                ...           a year ago
  • 1.0.1                                ...           a year ago
  • 1.0.0                                ...           a year ago
Downloads
Today 1
This Week 1
This Month 2
Last Day 0
Last Week 1
Last Month 1
Dependencies (2)
Dev Dependencies (0)
None
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |