@socifi/eslint-config-socifi
Shared ESLint config used in SOCIFI
Last updated 2 years ago by fabulator .
Apache License 2.0 · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @socifi/eslint-config-socifi 
SYNC missed versions from official npm registry.

ESLint Config SOCIFI

npm version

This is default ESlint configurations for projects in SOCIFI.

Usage

First install the package:

npm install @socifi/eslint-config-socifi --save-dev

and update you ESLint configuration:

module.exports = {
    extends: [
        '@socifi',
    ],
};

In basic configuration following plugins are included:

  • import - We use ECMAScript 6 modules.
  • jsdoc - Predefined style for comments of methods.
  • promise - Predefined style for promises.
  • compat - To check that used features are supported by certain browsers.
  • flowtype - We use static analysis tool Flow.

There are more extendable configurations for tests or different envs:

module.exports = {
    extends: [
        '@socifi',
        '@socifi/react',
        '@socifi/jasmine',
        '@socifi/jest',
        '@socifi/babel-resolver',
    ],
};

Current Tags

  • 1.6.0                                ...           latest (2 years ago)

2 Versions

  • 1.6.0                                ...           2 years ago
  • 1.0.0                                ...           2 years ago
Maintainers (1)
Downloads
Today 0
This Week 0
This Month 1
Last Day 0
Last Week 0
Last Month 3
Dev Dependencies (1)
Dependents (0)
None

Copyright 2014 - 2016 © taobao.org |