@gnodi/eslint-config
Lint your code like gnodi's one!
Last updated 2 years ago by gnodi .
MIT · Repository · Bugs · Original npm · Tarball · package.json
$ cnpm install @gnodi/eslint-config 
SYNC missed versions from official npm registry.

@gnodi/eslint-config

[Node.js] Lint your code like gnodi!

Build Version Downloads Dependencies Dev Dependencies

## Installation

Run the following command to add the package to your dev dependencies:

$ npm install --save-dev @gnodi/eslint-config

## Use

Use gnodi lint helper script

Add the following line to your package.json:

...
"scripts": {
  ...
  "lint": "gnodi-lint"
}
...

Then, you can immediately run the lint:

$ npm run lint

Add custom checked glob

By default, only js files from directories ., bin, config, lib, src and test are processed. You can add your own custom directories/files/globs passing it as arguments to your command gnodi-lint:

...
"scripts": {
  ...
  "lint": "gnodi-lint dist/bundle.js build/**/*.js"
}
...

Override with custom rules

You can override some rules with your own ones just using a standard .eslintrc:

{
  "extends": "@gnodi",
  "rules": {
    "comma-dangle": ["error", "always"]
  }
}

LICENSE

MIT

Current Tags

  • 0.4.0                                ...           latest (2 years ago)

5 Versions

  • 0.4.0                                ...           2 years ago
  • 0.3.0                                ...           2 years ago
  • 0.2.0                                ...           2 years ago
  • 0.1.0                                ...           2 years ago
  • 0.0.0                                ...           2 years ago
Maintainers (1)
Downloads
Today 0
This Week 5
This Month 5
Last Day 5
Last Week 0
Last Month 20
Dev Dependencies (0)
None
Dependents (1)

Copyright 2014 - 2016 © taobao.org |